CERN Accelerating science

Squid

Name of Supplier and/or Developer: 
Dave Dykstra
Contact details for Supplier and/or Developer: 
dwd@fnal.gov
Version: 
3.5.22
Release date: 
Thursday, October 13, 2016
Does developer claim IPv6 compliance?: 
Yes
From which version of the application does the developer claim IPv6 compliance?: 
3.5.22
Did you try running on dual stack system?: 
Yes
If so, did it break the application?: 
No
Does it bind to both stacks?: 
Yes
Is IPv6 preferred by default?: 
No
Can it be configured to prefer IPv6 or IPv4?: 
Yes
More information and/or link(s) to ticket(s): 
All squid 3.x versions are IPv6 compliant, but versions before 3.5.22 do not work properly on the WLCG applications Frontier and CVMFS.
Used by Experiment: 
ALICE
ATLAS
CMS
LHCb
How does it behave with a private IPv4 and a public IPv6?: 
It makes no distinction between private and public