CERN Accelerating science

MySQL / MariaDB

Name of Supplier and/or Developer: 
Oracle MySQL, MariaDB
Version: 
mysql 5.1.73
mysql 5.6.16
MariaDB 5.5.35
Does developer claim IPv6 compliance?: 
Yes
Did you try running on dual stack system?: 
Yes
If so, did it break the application?: 
No
Does it bind to both stacks?: 
Yes
More information and/or link(s) to ticket(s): 
MySQL provided from SL6 repositories does not support IPv6 (mysql Ver 14.14 Distrib 5.1.73) - For IPv6 either a recent Oracle MySQL (tested v5.6.16) or MariaDB (tested v5.5.35) is necessary. Successfully got connections between MariaDB client to Oracle MySQL server via IPv6 with the tested versions. The db configuration (standard location /etc/my.cnf ) has to be updated to bind to :: , e.g., [mysqld] bind-address = ::
Name of Tester: 
Thomas Hartmann
Used by Experiment: 
ALICE
ATLAS
CMS
LHCb